Using the InDesign Extension

Here’s how to enable the Collaborate extension for InDesign:

  1. Open up InDesign and pull down the Window menu. Under Extensions, choose issuu Collaborate.
  2. A Collaborate panel should appear and you can log in with your issuu profile (username or email).

 

Initially, the Layout tab is active and the flatplan for the chosen issue is now shown. You can see the status of the layout on the the colored bar at the bottom of each page:

Articles and ads are shown on the pages as well, with an icon next to the title, indicating its status.

Near the top of the window, you can select the Content tab.

For Contributors working on a publication’s layout, it is helpful to go to the Content tab to ensure that all the assets uploaded to an article are included when downloading via the extension.

 

Downloading content

Here’s how to download content into InDesign:

  1. Select the pages you want to download and click the Download button in the bottom right of the Collaborate panel in InDesign.
  2. The content will be downloaded to your computer and placed in the currently open InDesign document, right on the page in the InDesign document corresponding to the one selected in the extension.

 

File Sync, Layout and Production Status

  • The File Sync Status icons indicate if new, unsynced content is available.
  • The current status of the local content compared to the version on the server is indicated by an icon next to each page in the Layout view

 

  •  All add-on files that InDesign supports (copy from the Collaborate text editor, images, PDFs, Word documents, etc.) will be automatically imported into InDesign. 
  • If unsupported files were added to the article (such as a spreadsheet, among other files from digital tools), you’ll see them on the Content tab as well.
  • Initially, the Layout tab is active and the flatplan for the chosen issue is now shown. You can see the status of the layout on the the colored bar at the bottom of each page.
  • NOTE: "Not selectable" state is shown for items in pages that aren't actually available in your publication. For instance, if your publication on Collaborate has 20 pages, but the InDesign document has only page 1 through 10, then all the contents on pages 11 to 20 will be marked as "not selectable".

 

Uploading layouts

Once you are done with the layout for a page, select the page in the Collaborate panel and click Upload in the bottom left corner.

When you upload a layout, you can choose to add a comment to it and even notify a team member.

Here’s a tip: Both the Upload and Download actions can be performed on several pages at a time.

To do this,

  1. Simply click the pages that you want to upload or download; the marked pages have a darker background.
  2. You can use the usual mouse shortcuts (Shift-click, Command-click on Mac or Control-click on Windows) to select multiple pages at once.

 

Comments

Have more questions? Submit a request